[webkit-reviews] review granted: [Bug 66827] Unzip initialization lists and constructors in JSCell hierarchy (1/7) : [Attachment 105231] Change constructorBody to finishCreation

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 25 14:06:21 PDT 2011


Darin Adler <darin at apple.com> has granted Mark Hahnenberg
<mhahnenberg at apple.com>'s request for review:
Bug 66827: Unzip initialization lists and constructors in JSCell hierarchy
(1/7)
https://bugs.webkit.org/show_bug.cgi?id=66827

Attachment 105231: Change constructorBody to finishCreation
https://bugs.webkit.org/attachment.cgi?id=105231&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=105231&action=review


> Source/JavaScriptCore/runtime/JSString.h:312
> +	   // This constructor constructs a new string by concatenating v1, v2
& v3.

Probably should reword the comment since it’s not a constructor any more. But I
don’t want that to hold up this commit.

> Source/JavaScriptCore/runtime/JSString.h:330
> +	       appendStringInConstruct(index, u1);

Seems like this function should be named appendStringDuringCreation now. Again,
don’t want this to hold up this commit.


More information about the webkit-reviews mailing list