[webkit-reviews] review granted: [Bug 66383] [Qt][WK2] Add a basic engine to control the content of the viewport : [Attachment 104322] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 18 04:45:28 PDT 2011


Kenneth Rohde Christiansen <kenneth at webkit.org> has granted Benjamin Poulain
<benjamin at webkit.org>'s request for review:
Bug 66383: [Qt][WK2] Add a basic engine to control the content of the viewport
https://bugs.webkit.org/show_bug.cgi?id=66383

Attachment 104322: Patch
https://bugs.webkit.org/attachment.cgi?id=104322&action=review

------- Additional Comments from Kenneth Rohde Christiansen
<kenneth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=104322&action=review


> Source/WebKit2/ChangeLog:8
> +	   Add ViewportMotionEngine to handle the content of the viewport. The
class make

Wrong name

> Source/WebKit2/UIProcess/API/qt/qtouchwebview_p.h:46
> +    ViewportInteractionEngine interactionEngine;

Isn't this very Qt specific? Should it be prefixed with Qt ?

> Source/WebKit2/UIProcess/qt/ViewportInteractionEngine.h:109
> +    return (a.initialScale == b.initialScale && a.minimumScale ==
b.minimumScale && a.maximumScale == b.maximumScale
> +	       && a.isUserScalable == b.isUserScalable);

I guess the ()'s are not needed. I would put each && on a separate line.


More information about the webkit-reviews mailing list