[webkit-reviews] review denied: [Bug 66243] [GTK] Change webview API tests to use "load-status" signal instead of "load-progress" : [Attachment 103935] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 17 15:11:32 PDT 2011


Martin Robinson <mrobinson at webkit.org> has denied Caio Marcelo de Oliveira
Filho <cmarcelo at webkit.org>'s request for review:
Bug 66243: [GTK] Change webview API tests to use "load-status" signal instead
of "load-progress"
https://bugs.webkit.org/show_bug.cgi?id=66243

Attachment 103935: Patch
https://bugs.webkit.org/attachment.cgi?id=103935&action=review

------- Additional Comments from Martin Robinson <mrobinson at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=103935&action=review


> Source/WebKit/gtk/ChangeLog:10
> +	   The idle_quit_loop_cb() already checks the "load-status" flag, so it
should be
> +	   enough to call it when the "load-status" change.
> +

I'm not sure I understand why this patch is an improvement. Perhaps you could
expand a bit here.  It doesn't seem to remove any code. Does it make things
more efficient or more correct somehow?

> Source/WebKit/gtk/tests/testwebview.c:170
> +    g_signal_connect(view, "notify::load-status", G_CALLBACK
(idle_quit_loop_cb), NULL);

Do you mind also fixing the style issue here?  G_CALLBACK (idle_quit_loop_cb) 
G_CALLBACK(idle_quit_loop_cb)


More information about the webkit-reviews mailing list