[webkit-reviews] review granted: [Bug 65993] IndexedDB: Overwriting key in unique index should be possible : [Attachment 103499] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 11 10:24:09 PDT 2011


Tony Chang <tony at chromium.org> has granted Hans Wennborg <hans at chromium.org>'s
request for review:
Bug 65993: IndexedDB: Overwriting key in unique index should be possible
https://bugs.webkit.org/show_bug.cgi?id=65993

Attachment 103499: Patch
https://bugs.webkit.org/attachment.cgi?id=103499&action=review

------- Additional Comments from Tony Chang <tony at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=103499&action=review


> LayoutTests/storage/indexeddb/index-unique.html:141
> +    request.onsuccess = function() { done(); }

Nit: Can you just do request.onsuccess = done; ?

>> Source/WebCore/storage/IDBBackingStore.h:84

> 
> The parameter type should use PassRefPtr instead of RefPtr. 
[readability/pass_ptr] [5]

Nit: I would give the first IDBKey a name like searchKey to disambiguate it.

>> Source/WebCore/storage/IDBLevelDBBackingStore.h:70
>> +	virtual bool keyExistsInIndex(int64_t databaseId, int64_t
objectStoreId, int64_t indexId, const IDBKey&, RefPtr<IDBKey>&
foundPrimaryKey);
> 
> The parameter type should use PassRefPtr instead of RefPtr. 
[readability/pass_ptr] [5]

Ditto.

>> Source/WebCore/storage/IDBSQLiteBackingStore.h:65
>> +	virtual bool keyExistsInIndex(int64_t databaseId, int64_t
objectStoreId, int64_t indexId, const IDBKey&, RefPtr<IDBKey>&
foundPrimaryKey);
> 
> The parameter type should use PassRefPtr instead of RefPtr. 
[readability/pass_ptr] [5]

Ditto.


More information about the webkit-reviews mailing list