[webkit-reviews] review granted: [Bug 65799] String replace with the empty string means string removal : [Attachment 103133] The patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 5 17:34:29 PDT 2011


Sam Weinig <sam at webkit.org> has granted Gavin Barraclough
<barraclough at apple.com>'s request for review:
Bug 65799: String replace with the empty string means string removal
https://bugs.webkit.org/show_bug.cgi?id=65799

Attachment 103133: The patch
https://bugs.webkit.org/attachment.cgi?id=103133&action=review

------- Additional Comments from Sam Weinig <sam at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=103133&action=review


>> Source/JavaScriptCore/runtime/StringPrototype.cpp:271
>> +	PassRefPtr<StringImpl> impl =
StringImpl::tryCreateUninitialized(totalLength, buffer);
> 
> Local variables should never be PassRefPtr (see
http://webkit.org/coding/RefPtr.html).	[readability/pass_ptr] [5]

This is copy and pasted, but very wrong.  Please us a RefPtr and fix the other
spot.


More information about the webkit-reviews mailing list