[webkit-reviews] review granted: [Bug 59394] XMLDocumentParserLibxml2 should play nice with strict OwnPtrs : [Attachment 91707] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 29 11:54:15 PDT 2011


Darin Adler <darin at apple.com> has granted Maciej Stachowiak <mjs at apple.com>'s
request for review:
Bug 59394: XMLDocumentParserLibxml2 should play nice with strict OwnPtrs
https://bugs.webkit.org/show_bug.cgi?id=59394

Attachment 91707: Patch
https://bugs.webkit.org/attachment.cgi?id=91707&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=91707&action=review

>> Source/JavaScriptCore/wtf/Deque.h:37
>> +#include "PassTraits.h"
> 
> Alphabetical sorting problem.  [build/include_order] [4]

What the stylebot said ;-)

> Source/JavaScriptCore/wtf/Deque.h:55
> +	   typedef PassTraits<T> Pass;

Not 100% sure the name “Pass” is clear enough name for this. If it wasn’t for
the name conflict, I’d suggest calling it PassTraits.

>> Source/JavaScriptCore/wtf/PassTraits.h:41
>> +	template<typename T> struct PassTraits {
> 
> Code inside a namespace should not be indented.  [whitespace/indent] [4]

Would be better to follow the style guide here.

> Source/JavaScriptCore/wtf/PassTraits.h:44
> +	   static PassType transfer(Type& t) { return t; }

Is “t” the best name for this argument? Maybe “argument”? Or “object”?


More information about the webkit-reviews mailing list