[webkit-reviews] review denied: [Bug 42529] [Qt] Qt WebKit updates view on HTTP 204 response : [Attachment 88850] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 8 12:12:38 PDT 2011


Andreas Kling <kling at webkit.org> has denied Luiz Agostini <luiz at webkit.org>'s
request for review:
Bug 42529: [Qt] Qt WebKit updates view on HTTP 204 response
https://bugs.webkit.org/show_bug.cgi?id=42529

Attachment 88850: patch
https://bugs.webkit.org/attachment.cgi?id=88850&action=review

------- Additional Comments from Andreas Kling <kling at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=88850&action=review

> LayoutTests/ChangeLog:8
> +	   Responses which have status code equal to 204 should be ignored.

Oops! We're also changing the behavior of 205 responses without a test or
mention.

> Source/WebKit/qt/WebCoreSupport/FrameLoaderClientQt.cpp:609
>      if (m_webFrame && m_frame->page())
> -	   emit loadFinished(m_loadError.isNull());
> +	   emit loadFinished(m_loadError.isNull() ||
m_loadError.isCancellation());

This looks vaguely unrelated, what's this change about, and how can we test it?


> Source/WebKit/qt/WebCoreSupport/FrameLoaderClientQt.h:281
> +    enum HTTPStatusCodes {
> +	   NoContent = 204,
> +	   ResetContent = 205
> +    };

This enum should be called HTTPStatusCode, and I think we should put it in a
central location, something like
Source/WebCore/platform/network/HTTPStatusCode.h
There are a number of places in WebKit that would look nicer without such
numeric constants inline.
I also think the values should be prefixed with HTTP, i.e HTTPNoContent,
HTTPResetContent.


More information about the webkit-reviews mailing list