[webkit-reviews] review denied: [Bug 44329] SH4 JIT SUPPORT : [Attachment 88821] JIT remaining part for SH4 platforms.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 8 10:30:27 PDT 2011

Oliver Hunt <oliver at apple.com> has denied thouraya <thouraya.andolsi at st.com>'s
request for review:
Bug 44329: SH4 JIT SUPPORT

Attachment 88821: JIT remaining part for SH4 platforms.

------- Additional Comments from Oliver Hunt <oliver at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=88821&action=review

r- due to naming issue, almost there.

> Source/JavaScriptCore/jit/JIT.h:710
> +#define END_UNINTERRUPTED_SEQUENCE2(name, dst) do {
endUninterruptedSequence(name ## InstructionSpace, name ## ConstantSpace, dst);
} while (false)

This is a bad name, if anything END_UNINTERRUPTED_SEQUENCE_FOR_PUT might be

> Source/JavaScriptCore/jit/JITInlineMethods.h:143
> +ALWAYS_INLINE void JIT::endUninterruptedSequence(int insnSpace, int
constSpace, int dst)

Does the arm build work with this change?  afaict it should fail due to dst
being unused.

You could put UNUSED_PARAM(dst) in the function to deal with that.

More information about the webkit-reviews mailing list