[webkit-reviews] review granted: [Bug 58128] -[WebView setPreferences:] can take a lot of time if loading lots of webviews at once : [Attachment 88788] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 8 10:17:45 PDT 2011


Darin Adler <darin at apple.com> has granted Maciej Stachowiak <mjs at apple.com>'s
request for review:
Bug 58128: -[WebView setPreferences:] can take a lot of time if loading lots of
webviews at once
https://bugs.webkit.org/show_bug.cgi?id=58128

Attachment 88788: Patch
https://bugs.webkit.org/attachment.cgi?id=88788&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=88788&action=review

> Source/WebKit/mac/WebView/WebPreferences.mm:1189
> +    [[NSNotificationCenter defaultCenter]
> +	   postNotificationName:WebPreferencesChangedInternalNotification
object:self
> +		       userInfo:nil];
> +    [[NSNotificationCenter defaultCenter]
> +	   postNotificationName:WebPreferencesChangedNotification object:self
> +		       userInfo:nil];

I don’t like lining these up. Probably would read better all on one line.

> Source/WebKit/mac/WebView/WebPreferencesPrivate.h:54
> +extern NSString *WebPreferencesChangedInternalNotification;

If this is an internal notification then it should probably be in an internal
header, not a private header.

> Source/WebKit/mac/WebView/WebPreferencesPrivate.h:215
> -- (void)_postPreferencesChangesNotification;
> +- (void)_postPreferencesChangedNotification;
> +- (void)_postPreferencesChangedAPINotification;

If these are private methods they may be used in applications that make use of
SPI. Can we really rename them safely?

If these are internal methods they should be in an internal header, not a
private one.


More information about the webkit-reviews mailing list