[webkit-reviews] review granted: [Bug 46938] Rewrite margin collapsing to be block-flow-aware : [Attachment 69385] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 30 14:48:14 PDT 2010


Sam Weinig <sam at webkit.org> has granted Dave Hyatt <hyatt at apple.com>'s request
for review:
Bug 46938: Rewrite margin collapsing to be block-flow-aware
https://bugs.webkit.org/show_bug.cgi?id=46938

Attachment 69385: Patch
https://bugs.webkit.org/attachment.cgi?id=69385&action=review

------- Additional Comments from Sam Weinig <sam at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=69385&action=review

> WebCore/rendering/RenderBlock.h:190
> +    struct MarginValues
> +    {

The { should be on the same line as struct MarginValues

> WebCore/rendering/RenderBlock.h:212
> +	   
> +	   int beforePos() const { return m_beforePos; }
> +	   int beforeNeg() const { return m_beforeNeg; }
> +	   int afterPos() const { return m_afterPos; }
> +	   int afterNeg() const { return m_afterNeg; }
> +	   
> +	   void setBeforePos(int pos) { m_beforePos = pos; }
> +	   void setBeforeNeg(int neg) { m_beforeNeg = neg; }
> +	   void setAfterPos(int pos) { m_afterPos = pos; }
> +	   void setAfterNeg(int neg) { m_afterNeg = neg; }
> +
> +	   int m_beforePos;
> +	   int m_beforeNeg;
> +	   int m_afterPos;
> +	   int m_afterNeg;
> +    };

What is the purpose of these getter and setters. can we just remove the m_ from
the members and remove the functions?


I think replacing neg with negative and pos with positive would make this code
read better.


More information about the webkit-reviews mailing list