[webkit-reviews] review denied: [Bug 46090] [chromium] expose the filename used for a given indexed DB : [Attachment 68082] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 20 08:00:05 PDT 2010


Jeremy Orlow <jorlow at chromium.org> has denied jochen at chromium.org's request for
review:
Bug 46090: [chromium] expose the filename used for a given indexed DB
https://bugs.webkit.org/show_bug.cgi?id=46090

Attachment 68082: Patch
https://bugs.webkit.org/attachment.cgi?id=68082&action=review

------- Additional Comments from Jeremy Orlow <jorlow at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=68082&action=review

> WebCore/storage/IDBFactoryBackendInterface.cpp:48
> +String IDBFactoryBackendInterface::fileNameForIDB(const String& name,
SecurityOrigin* securityOrigin)

Let's not duplicate code.  See below comment.

> WebCore/storage/IDBFactoryBackendInterface.h:57
> +    static String fileNameForIDB(const String& name, SecurityOrigin*);

Put this on the Impl.h/cpp since the interface.cpp has a chromium and a
non-chromium version.  It's fine to leave the WebKit side of things as is tho.

> WebCore/storage/chromium/IDBFactoryBackendInterface.cpp:32
> +#include "FileSystem.h"

remove (per my above comment)

> WebCore/storage/chromium/IDBFactoryBackendInterface.cpp:44
> +String IDBFactoryBackendInterface::fileNameForIDB(const String& name,
SecurityOrigin* securityOrigin)

remove (per my above comment)


More information about the webkit-reviews mailing list