[webkit-reviews] review denied: [Bug 45872] Refactor HTMLInputElement : [Attachment 67768] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 16 07:18:15 PDT 2010


Dimitri Glazkov (Google) <dglazkov at chromium.org> has denied Kent Tamura
<tkent at chromium.org>'s request for review:
Bug 45872: Refactor HTMLInputElement
https://bugs.webkit.org/show_bug.cgi?id=45872

Attachment 67768: Patch
https://bugs.webkit.org/attachment.cgi?id=67768&action=review

------- Additional Comments from Dimitri Glazkov (Google)
<dglazkov at chromium.org>
View in context:
https://bugs.webkit.org/attachment.cgi?id=67768&action=prettypatch

Yay! This is exactly what we need. However, I think you're not handling a case
of changing input type by setting the value of the "input" attribute. Even
though the input may be born as a text input, it could change to any other type
during its lifecycle.

> WebCore/html/HTMLInputElement.cpp:2957
> +// Type handlers
---------------------------------------------------------------

This should live either in separate files (preferred) or with TypeHandle
(InputType).

> WebCore/html/HTMLInputElement.h:41
> +class TypeHandler {

This needs to be moved to its own file. Also, can we name it something more
specific, like InputType? Then, the subclasses could be TextInputType,
CheckboxInputType, etc.


More information about the webkit-reviews mailing list