[webkit-reviews] review granted: [Bug 45779] Exceptions are getting ignored on 64-bit Windows in the Web Process : [Attachment 67602] Clear the PROCESS_CALLBACK_FILTER_ENABLED flag

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 14 14:15:29 PDT 2010


Adam Roben (aroben) <aroben at apple.com> has granted Jessie Berlin
<jberlin at webkit.org>'s request for review:
Bug 45779: Exceptions are getting ignored on 64-bit Windows in the Web Process
https://bugs.webkit.org/show_bug.cgi?id=45779

Attachment 67602: Clear the PROCESS_CALLBACK_FILTER_ENABLED flag
https://bugs.webkit.org/attachment.cgi?id=67602&action=review

------- Additional Comments from Adam Roben (aroben) <aroben at apple.com>
View in context:
https://bugs.webkit.org/attachment.cgi?id=67602&action=prettypatch

> WebKit2/WebProcess/WebKitMain.cpp:82
> +static void disableProcessCallbackFilterForExceptions()
I think disableUserModeCallbackExceptionFilter would be a clearer name.

> WebKit2/WebProcess/WebKitMain.cpp:84
> +    DWORD dwFlags;
You should move this declaration to just before it's used.

> WebKit2/WebProcess/WebKitMain.cpp:104
> +    setPolicyPtr(dwFlags & ~0x1);
I think you should make a named constant for 0x1.

It would probably be useful to link to
<http://blog.paulbetts.org/index.php/2010/07/20/the-case-of-the-disappearing-on
load-exception-user-mode-callback-exceptions-in-x64/>, at least in your
ChangeLog.

> WebKitSite/building/tools.html:63
> +<li><p>Optional: Hotfix for 64-bit Windows to disable the process callback
filter for exceptions</p>
I'd say "user-mode" instead of "process" here.

r=me


More information about the webkit-reviews mailing list