[webkit-reviews] review granted: [Bug 47365] getTextAtOffset returns incorrect results if a link includes text and an image : [Attachment 71852] Patch proposal + unit test

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 27 00:57:46 PDT 2010


Martin Robinson <mrobinson at webkit.org> has granted Mario Sanchez Prada
<msanchez at igalia.com>'s request for review:
Bug 47365: getTextAtOffset returns incorrect results if a link includes text
and an image
https://bugs.webkit.org/show_bug.cgi?id=47365

Attachment 71852: Patch proposal + unit test
https://bugs.webkit.org/attachment.cgi?id=71852&action=review

------- Additional Comments from Martin Robinson <mrobinson at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=71852&action=review

Great! Thanks. Perhaps make this small change before landing:

> WebKit/gtk/tests/testatk.c:985
> +    AtkObject* obj = gtk_widget_get_accessible(GTK_WIDGET(webView));
> +    g_assert(obj);
> +
> +    // First paragraph (link at the beginning)
> +    AtkObject* paragraph = atk_object_ref_accessible_child(obj, 0);

Please rename obj to something like "object" to avoid the abbreviation.


More information about the webkit-reviews mailing list