[webkit-reviews] review denied: [Bug 25539] spellcheck='' should be the same as spellcheck="true" : [Attachment 71543] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 22 10:17:24 PDT 2010


Tony Chang <tony at chromium.org> has denied MORITA Hajime <morrita at google.com>'s
request for review:
Bug 25539: spellcheck='' should be the same as spellcheck="true"
https://bugs.webkit.org/show_bug.cgi?id=25539

Attachment 71543: Patch
https://bugs.webkit.org/attachment.cgi?id=71543&action=review

------- Additional Comments from Tony Chang <tony at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=71543&action=review

> WebCore/dom/Element.h:327
> +    SpellcheckAttributeState spellcheckAttributeState() const;

Can this method be private?

> WebCore/dom/Element.h:328
> +    bool spellCheckingEnabled() const;

I would name this isSpellCheckingEnabled to match similar methods.

> WebCore/editing/Editor.cpp:2551
> +    const Element* focusedElement = node->isElementNode() ? toElement(node)
: node->parentElement();

Is it possible that node->parentElement() is null, but
node->parent()->parentElement() is true?


More information about the webkit-reviews mailing list