[webkit-reviews] review granted: [Bug 47275] Web Inspector: inspector settings/properties/states management should be extracted into separate class. : [Attachment 70737] [patch] next iteration.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 14 13:13:05 PDT 2010


Pavel Feldman <pfeldman at chromium.org> has granted Ilya Tikhonovsky
<loislo at chromium.org>'s request for review:
Bug 47275: Web Inspector: inspector settings/properties/states management
should be extracted into separate class.
https://bugs.webkit.org/show_bug.cgi?id=47275

Attachment 70737: [patch] next iteration.
https://bugs.webkit.org/attachment.cgi?id=70737&action=review

------- Additional Comments from Pavel Feldman <pfeldman at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=70737&action=review

> WebCore/inspector/InspectorController.cpp:400
> +    if (!enabled() ||
!m_state->getBoolean(InspectorState::searchingForNode))

Use !searchingForNodeInPage() here?

> WebCore/inspector/InspectorController.cpp:415
> +    ASSERT(m_state->getBoolean(InspectorState::searchingForNode));

ditto

> WebCore/inspector/InspectorController.cpp:454
> +    if (m_state->getBoolean(InspectorState::searchingForNode) == enabled)

ditto

> WebCore/inspector/InspectorController.cpp:1111
> +    if (!enabled() ||
!m_state->getBoolean(InspectorState::resourceTrackingEnabled))

resourceTrackingEnabled() ?

> WebCore/inspector/InspectorController.cpp:1140
> +    if (m_state->getBoolean(InspectorState::resourceTrackingEnabled) ==
enable)

ditto

> WebCore/inspector/InspectorState.cpp:44
> +    registerBoolean(resourceTrackingAlwaysEnabled, false, (const char*)0,
"resourceTrackingEnabled");

This is likely to add the confusion (resourceTrackingAlwaysEnabled is persisted
as "resourceTrackingEnabled".

> WebCore/inspector/InspectorState.cpp:170
> +InspectorState::Property
InspectorState::Property::create(PassRefPtr<InspectorValue> value, const
String& stateName, const String& preferenceName)

stateName is not used anywhere other than in the front-end. InspectorController
itself uses enum literals. Should we rename "stateName" to "frontendAlias"?


More information about the webkit-reviews mailing list