[webkit-reviews] review requested: [Bug 44992] [chromium] Prepare Clipboard/DragData for transition to new drag-and-drop interface. : [Attachment 70457] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 11 11:28:23 PDT 2010


Daniel Cheng <dcheng at chromium.org> has asked  for review:
Bug 44992: [chromium] Prepare Clipboard/DragData for transition to new
drag-and-drop interface.
https://bugs.webkit.org/show_bug.cgi?id=44992

Attachment 70457: Patch
https://bugs.webkit.org/attachment.cgi?id=70457&action=review

------- Additional Comments from Daniel Cheng <dcheng at chromium.org>
(In reply to comment #25)
> (From update of attachment 70318 [details])
> View in context:
https://bugs.webkit.org/attachment.cgi?id=70318&action=review
> 
> > WebCore/platform/chromium/ClipboardChromium.cpp:93
> > +	     policy == ClipboardWritable
> > +	     ? ChromiumDataObject::createWritable(clipboardType)
> > +	     : ChromiumDataObject::createReadable(clipboardType);
> 
> In RDO.cpp, you put the ternary operator at the end of lines.  Can you be
consistent?  I'm not sure there's an actual style rule. In practice, most
people just put the whole expression on a single line (which also seems fine to
me).

Changed to use RDO style, since that was taken from existing code.

> 
> > WebCore/platform/chromium/ReadableDataObject.cpp:82
> > +		     Pasteboard::generalPasteboard()->isSelectionMode() ?
> > +		     PasteboardPrivate::SelectionBuffer :
> > +		     PasteboardPrivate::StandardBuffer;
> 
> This is where you use the opposite style.
> 
> > WebKit/chromium/public/WebView.h:228
> > +	 virtual WebDragOperation dragTargetDragEnter2(
> > +	     int identity, const WebPoint& clientPoint, const WebPoint&
screenPoint,
> > +	     WebDragOperationsMask operationsAllowed) = 0;
> 
> I have a slight preference to using dragTargetDragEnterNew rather than 2, but
either is ok.

Done.


More information about the webkit-reviews mailing list