[webkit-reviews] review granted: [Bug 46543] Fix passing blob data with string data item between threads : [Attachment 70179] Proposed Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 8 00:34:49 PDT 2010


David Levin <levin at chromium.org> has granted Jian Li <jianli at chromium.org>'s
request for review:
Bug 46543: Fix passing blob data with string data item between threads
https://bugs.webkit.org/show_bug.cgi?id=46543

Attachment 70179: Proposed Patch
https://bugs.webkit.org/attachment.cgi?id=70179&action=review

------- Additional Comments from David Levin <levin at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=70179&action=review

> WebCore/fileapi/BlobBuilder.cpp:53
> +    if (!endingType.isEmpty() && !isEndingTypeTransparent &&
!isEndingTypeNative) {

This looks like an interesting error. Is there a test case for it? Could there
be one?

> WebCore/platform/text/LineEnding.cpp:73
> +#if OS(WINDOWS)

I wouldn't ifdef this because it make it confusing to try to guess why it is
ifdef'ed out.

> WebCore/platform/text/LineEnding.cpp:128
> +    char* q = buffer.allocate(newLen);

It would be nice to have a more descriptive variable name than "q".


More information about the webkit-reviews mailing list