[webkit-reviews] review granted: [Bug 46963] Add helper methods to cast between renderers & SVGTextContent/PositioningElement : [Attachment 69428] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 1 00:15:21 PDT 2010


Dirk Schulze <krit at webkit.org> has granted Nikolas Zimmermann
<zimmermann at kde.org>'s request for review:
Bug 46963: Add helper methods to cast between renderers &
SVGTextContent/PositioningElement
https://bugs.webkit.org/show_bug.cgi?id=46963

Attachment 69428: Patch
https://bugs.webkit.org/attachment.cgi?id=69428&action=review

------- Additional Comments from Dirk Schulze <krit at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=69428&action=review

The patch itself looks good to me. r=me with the fixes.

> WebCore/svg/SVGTextContentElement.cpp:219
> +SVGTextContentElement* SVGTextContentElement::fromRenderer(RenderObject*
renderer)

Another name for 'fromRenderer' is maybe more self-explanatory. Niko suggested
elementFromRenderer.

> WebCore/svg/SVGTextContentElement.cpp:238
> +    if (!node->hasTagName(SVGNames::textTag)
> +	&& !node->hasTagName(SVGNames::tspanTag)
> +#if ENABLE(SVG_FONTS)
> +	&& !node->hasTagName(SVGNames::altGlyphTag)
> +#endif
> +	&& !node->hasTagName(SVGNames::trefTag)
> +	&& !node->hasTagName(SVGNames::textPathTag))
> +	   return 0;

The indention is wrong.

> WebCore/svg/SVGTextPositioningElement.cpp:164
> +    if (!node->hasTagName(SVGNames::textTag)
> +	&& !node->hasTagName(SVGNames::tspanTag)
> +#if ENABLE(SVG_FONTS)
> +	&& !node->hasTagName(SVGNames::altGlyphTag)
> +#endif
> +	&& !node->hasTagName(SVGNames::trefTag))
> +	   return 0;

wrong indention.


More information about the webkit-reviews mailing list