[webkit-reviews] review denied: [Bug 49779] nrwt multiprocessing - implement first part of broker object : [Attachment 74455] update w/ review feedback

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 19 19:07:39 PST 2010


Tony Chang <tony at chromium.org> has denied Dirk Pranke <dpranke at chromium.org>'s
request for review:
Bug 49779: nrwt multiprocessing - implement first part of broker object
https://bugs.webkit.org/show_bug.cgi?id=49779

Attachment 74455: update w/ review feedback
https://bugs.webkit.org/attachment.cgi?id=74455&action=review

------- Additional Comments from Tony Chang <tony at chromium.org>
r- only because it seems like we should resolve the workers-are naming issue in
bug 49773 first.

View in context: https://bugs.webkit.org/attachment.cgi?id=74455&action=review

> WebKitTools/Scripts/webkitpy/layout_tests/layout_package/message_broker.py:65

> +	   self.name = None

self.name = name

> WebKitTools/Scripts/webkitpy/layout_tests/layout_package/message_broker.py:74

> +	   self._workers = {}

Nit: maybe a comment saying this maps worker names to _WorkerState?

> WebKitTools/Scripts/webkitpy/layout_tests/layout_package/message_broker.py:77

> +	   return [w.thread for w in self._workers.values()]

Nit: Should this return a tuple instead of a list?

> WebKitTools/Scripts/webkitpy/layout_tests/layout_package/message_broker.py:98

> +	   """Loop processing messages until done. Returns nothing."""

I don't think you need to say the method returns nothing.  I was just confused
before because of the implementation returning false.  Same with cancel_workers
and cleanup.


More information about the webkit-reviews mailing list