[webkit-reviews] review denied: [Bug 49767] Make sure is* return false if the name is never bound : [Attachment 74325] revised patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 19 12:18:22 PST 2010


Kenneth Russell <kbr at google.com> has denied Zhenyao Mo <zmo at google.com>'s
request for review:
Bug 49767: Make sure is* return false if the name is never bound
https://bugs.webkit.org/show_bug.cgi?id=49767

Attachment 74325: revised patch
https://bugs.webkit.org/attachment.cgi?id=74325&action=review

------- Additional Comments from Kenneth Russell <kbr at google.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=74325&action=review

The naming convention for these new methods is poor. The general rule is to
name methods so clearly that comments aren't needed. This is especially true in
a case like this where the methods are so simple.

> WebCore/html/canvas/WebGLBuffer.h:62
> +    bool bound() const { return object() && m_target; }

bool hasEverBeenBound() const

> WebCore/html/canvas/WebGLFramebuffer.h:59
> +    // Return false if it is never bound; otherwise return true.

Useless comment.

> WebCore/html/canvas/WebGLFramebuffer.h:60
> +    bool bound() const { return object() && m_bound; }

bool hasEverBeenBound() const

> WebCore/html/canvas/WebGLFramebuffer.h:62
> +    void setBound() { m_bound = true; }

void setHasEverBeenBound()

> WebCore/html/canvas/WebGLRenderbuffer.h:63
> +    // Return false if it is never bound; otherwise return true.

Useless comment.

> WebCore/html/canvas/WebGLRenderbuffer.h:66
> +    bool bound() const { return object() && m_bound; }
> +
> +    void setBound() { m_bound = true; }

Naming.

> WebCore/html/canvas/WebGLTexture.h:64
> +    bool bound() const { return object() && m_target; }

bool hasEverBeenBound()


More information about the webkit-reviews mailing list