[webkit-reviews] review denied: [Bug 25678] [GTK] Implement ROLE_COMBO_BOX : [Attachment 74116] Patch proposal + Unit test

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 17 09:19:41 PST 2010


Martin Robinson <mrobinson at webkit.org> has denied Mario Sanchez Prada
<msanchez at igalia.com>'s request for review:
Bug 25678: [GTK] Implement ROLE_COMBO_BOX
https://bugs.webkit.org/show_bug.cgi?id=25678

Attachment 74116: Patch proposal + Unit test
https://bugs.webkit.org/attachment.cgi?id=74116&action=review

------- Additional Comments from Martin Robinson <mrobinson at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=74116&action=review

Nice patch. I have a couple questions...

> WebCore/ChangeLog:23
> +	   of that methor to an overriden version of stringValue(), which is

methor -> method

> WebCore/accessibility/AccessibilityMenuListOption.cpp:113
> +String AccessibilityMenuListOption::stringValue() const

I'm not sure about the naming here. Maybe Chris can give the nod.

> WebCore/accessibility/gtk/AccessibilityObjectWrapperAtk.cpp:768
> +	   const Vector<Element*> listItems = selectNode->listItems();
>  
> -    // TODO: Combo boxes
> +	   if (selectedIndex < 0 || selectedIndex >= (int)listItems.size())

Is it possible for the selectedIndex to be > listeItems.size()? It doesn't look
like it after staring at SelectElement::selectedIndex. If you still need to
cast to int, be sure to use a static_cast.

> WebCore/platform/gtk/PopupMenuGtk.cpp:65
> -    int x, y;
> -   
gdk_window_get_origin(gtk_widget_get_window(GTK_WIDGET(view->hostWindow()->plat
formPageClient())), &x, &y);
> +    int x = 0;
> +    int y = 0;
> +    GdkWindow* window =
gtk_widget_get_window(GTK_WIDGET(view->hostWindow()->platformPageClient()));
> +    if (window)
> +	   gdk_window_get_origin(window, &x, &y);

Is this change related?


More information about the webkit-reviews mailing list