[webkit-reviews] review granted: [Bug 49469] ScriptElement rather than HTMLScriptElement and SVGScriptElement should have ScriptElementData : [Attachment 73773] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 15 14:21:45 PST 2010


Darin Adler <darin at apple.com> has granted Ryosuke Niwa <rniwa at webkit.org>'s
request for review:
Bug 49469: ScriptElement rather than HTMLScriptElement and SVGScriptElement
should have ScriptElementData
https://bugs.webkit.org/show_bug.cgi?id=49469

Attachment 73773: Patch
https://bugs.webkit.org/attachment.cgi?id=73773&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=73773&action=review

> WebCore/dom/ScriptElement.h:79
> +    : m_data(this, element, isEvaluated)

Formatting is wrong here. This should be indented.

> WebCore/dom/ScriptElement.h:101
> +    virtual String sourceAttributeValue() const = 0;
> +    virtual String charsetAttributeValue() const = 0;
> +    virtual String typeAttributeValue() const = 0;
> +    virtual String languageAttributeValue() const = 0;
> +    virtual String forAttributeValue() const = 0;
> +    virtual String eventAttributeValue() const = 0;
> +    virtual bool asyncAttributeValue() const = 0;
> +    virtual bool deferAttributeValue() const = 0;
> +
> +    virtual void dispatchLoadEvent() = 0;
> +    virtual void dispatchErrorEvent() = 0;

I think these should all be private. We can refactor to accomplish this in a
later patch.


More information about the webkit-reviews mailing list