[webkit-reviews] review granted: [Bug 49418] Add didReceiveResponse and didReceiveData to the download client : [Attachment 73684] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Nov 11 17:29:57 PST 2010


Darin Adler <darin at apple.com> has granted Anders Carlsson
<andersca at apple.com>'s request for review:
Bug 49418: Add didReceiveResponse and didReceiveData to the download client
https://bugs.webkit.org/show_bug.cgi?id=49418

Attachment 73684: Patch
https://bugs.webkit.org/attachment.cgi?id=73684&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=73684&action=review

> WebKit2/UIProcess/API/C/WKContext.h:77
> +typedef void (*WKContextDownloadDidReceiveResponseCallback)(WKContextRef
context, WKDownloadRef download, WKURLResponseRef response, const void
*clientInfo);
> +typedef void (*WKContextDownloadDidReceiveDataCallback)(WKContextRef
context, WKDownloadRef download, uint64_t length, const void *clientInfo);
>  typedef void (*WKContextDownloadDidCreateDestinationCallback)(WKContextRef
context, WKDownloadRef download, WKStringRef path, const void *clientInfo);
> +typedef void (*WKContextDownloadDidFinishCallback)(WKContextRef context,
WKDownloadRef download, const void *clientInfo);

Can we do "const void*" instead of "const void *"?


More information about the webkit-reviews mailing list