[webkit-reviews] review granted: [Bug 48844] Make RenderStyle::playState() return typed value and cleanup naming in Animation code" : [Attachment 72689] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 2 09:56:39 PDT 2010


Adam Roben (aroben) <aroben at apple.com> has granted Chris Marrin
<cmarrin at apple.com>'s request for review:
Bug 48844: Make RenderStyle::playState() return typed value and cleanup naming
in Animation code"
https://bugs.webkit.org/show_bug.cgi?id=48844

Attachment 72689: Patch
https://bugs.webkit.org/attachment.cgi?id=72689&action=review

------- Additional Comments from Adam Roben (aroben) <aroben at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=72689&action=review

> WebCore/page/animation/CompositeAnimation.h:102
> -    bool m_isSuspended;
> +    bool m_suspended;

I think this is a step in the wrong direction, but I guess consistency is a
good thing.

> WebCore/platform/animation/Animation.h:137
> -    unsigned m_playState	: 2;
> +    EAnimPlayState m_playState     : 2;

You need to keep this an unsigned bitfield. Enum bitfields are signed under
MSVC, and that will screw up comparison operations. You should cast to
EAnimPlayState in the getter.


More information about the webkit-reviews mailing list