[webkit-reviews] review denied: [Bug 39083] Refactor FormData and Blob for better support of Blobs synthesized by BlobBuilder : [Attachment 57018] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 25 13:59:53 PDT 2010


Jian Li <jianli at chromium.org> has denied Kinuko Yasuda <kinuko at chromium.org>'s
request for review:
Bug 39083: Refactor FormData and Blob for better support of Blobs synthesized
by BlobBuilder
https://bugs.webkit.org/show_bug.cgi?id=39083

Attachment 57018: Patch
https://bugs.webkit.org/attachment.cgi?id=57018&action=review

------- Additional Comments from Jian Li <jianli at chromium.org>
WebCore/platform/BlobItem.cpp:74
 +  char* DataBlobItem::deepCopyBuffer() const
Probably copyBuffer() sounds simpler.

WebCore/platform/BlobItem.cpp:111
 +  bool FileBlobItem::isValid() const
This validity check is not necessary because the check is done when we open a
file to read.
Please also remove isValid() from FileBlobItem class definition.

WebCore/platform/BlobItem.cpp:141
 +  
Please remove the extra empty line.

WebCore/platform/network/FormData.cpp:171
 +  void FormData::appendBlobItemList(const BlobItemList& list)
This method is very confusing with appendItems because both take BlobItemList
and the names sound similar while the semantics are very different.
How about naming this method as appendItems (or appendBlobItems) and the other
one as appendKeyValuePairItems (or appendBlobItemsInKeyValuePair)?


More information about the webkit-reviews mailing list