[webkit-reviews] review granted: [Bug 39329] [WinCairo] Correct scaling for print preview : [Attachment 56425] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 20 06:47:48 PDT 2010


Adam Roben (aroben) <aroben at apple.com> has granted Brent Fulgham
<bfulgham at webkit.org>'s request for review:
Bug 39329: [WinCairo] Correct scaling for print preview
https://bugs.webkit.org/show_bug.cgi?id=39329

Attachment 56425: Patch
https://bugs.webkit.org/attachment.cgi?id=56425&action=review

------- Additional Comments from Adam Roben (aroben) <aroben at apple.com>
WebKit/win/ChangeLog:8
 +	    Cairo does not properly deal with Windows HDC's that have been
There's no apostrophe in "HDCs".

WebKit/win/ChangeLog:13
 +	    Instead, reset the HDC's WorldTransform to unity, scale the
Here, too.

I think maybe you mean "identity" instead of "unity".

WebKit/win/WebFrame.cpp:2166
 +	int y = max(static_cast<int>(headerHeight) + pageRect.height(),
m_pageHeight  -static_cast<int>(footerHeight));
Weird spacing around the - operator here.

WebKit/win/WebFrame.cpp:2172
 +  static XFORM buildXformFromCairo(HDC targetDC, cairo_t* cr)
I think WebKit naming conventions say this should be buildXFORMFromCairo.

Is there a better name we can use than "cr"?

WebKit/win/WebFrame.cpp:2247
 +  static void setCairoToHDC(cairo_t* cr, HDC targetDC)
Again, a better name than "cr" would be nice.

I agree that this function could use a better name.

WebKit/win/WebFrame.cpp:2252
 +	XFORM revertedCTM(passedCTM);
Using constructor syntax here is a little surprising.


More information about the webkit-reviews mailing list