[webkit-reviews] review granted: [Bug 38891] REGRESSION (r57657): Incorrect font-size of :first-letter when using cufon.js : [Attachment 55881] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 12 11:56:20 PDT 2010


Darin Adler <darin at apple.com> has granted Dave Hyatt <hyatt at apple.com>'s
request for review:
Bug 38891: REGRESSION (r57657): Incorrect font-size of :first-letter when using
cufon.js
https://bugs.webkit.org/show_bug.cgi?id=38891

Attachment 55881: Patch
https://bugs.webkit.org/attachment.cgi?id=55881&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
> -    while (currChild && currChild->needsLayout() &&
((!currChild->isReplaced() && !currChild->isRenderButton() &&
!currChild->isMenuList()) || currChild->isFloatingOrPositioned()) &&
!currChild->isText()) {
> +    while (currChild && ((!currChild->isReplaced() &&
!currChild->isRenderButton() && !currChild->isMenuList()) ||
currChild->isFloatingOrPositioned()) && !currChild->isText()) {

Is there a way to make this more readable with a helper function for the
boolean test here?

> -	       if (currChild->style()->styleType() == FIRST_LETTER)
> +	       if (currChild->style()->styleType() == FIRST_LETTER) {
> +		   currChild = currChild->firstChild();
>		   break;
> +	       } else
> +		   currChild = currChild->nextSibling();

No need for else after break.

r=me


More information about the webkit-reviews mailing list