[webkit-reviews] review granted: [Bug 36259] <input type=range> does not validate correctly without a renderer and the tests are incorrect : [Attachment 51118] [PATCH] Part 2 - Added ASSERTs, Fixed Style Issue in Part 1

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 18 19:00:46 PDT 2010


David Kilzer (ddkilzer) <ddkilzer at webkit.org> has granted Joseph Pecoraro
<joepeck at webkit.org>'s request for review:
Bug 36259: <input type=range> does not validate correctly without a renderer
and the tests are incorrect
https://bugs.webkit.org/show_bug.cgi?id=36259

Attachment 51118: [PATCH] Part 2 - Added ASSERTs, Fixed Style Issue in Part 1
https://bugs.webkit.org/attachment.cgi?id=51118&action=review

------- Additional Comments from David Kilzer (ddkilzer) <ddkilzer at webkit.org>
> diff --git a/WebCore/html/HTMLInputElement.cpp
b/WebCore/html/HTMLInputElement.cpp

Nit:  Update copyright.

> +    case RANGE: // Guarenteed by sanitization.
> +	   ASSERT(parseToDouble(value(), nan) <= maximum());

Typo:  Guaranteed

> +    case RANGE: // Guarenteed by sanitization.
> +	   ASSERT(parseToDouble(value(), nan) <= maximum());

Typo:  Guaranteed

> diff --git a/WebCore/html/StepRange.cpp b/WebCore/html/StepRange.cpp
> +double StepRange::clampValue(const String& stringValue)
> +{
> +    double oldValue;

I would call this value since "oldValue" implies a "newValue", and we don't
have one of those here.

r=me


More information about the webkit-reviews mailing list