[webkit-reviews] review denied: [Bug 36175] [Qt] Make QtLaucher able to select the ViewportUpdateMode : [Attachment 50811] Proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 16 11:28:08 PDT 2010


Kenneth Rohde Christiansen <kenneth at webkit.org> has denied Diego Gonzalez
<diego.gonzalez at openbossa.org>'s request for review:
Bug 36175: [Qt] Make QtLaucher able to select the ViewportUpdateMode
https://bugs.webkit.org/show_bug.cgi?id=36175

Attachment 50811: Proposed patch
https://bugs.webkit.org/attachment.cgi?id=50811&action=review

------- Additional Comments from Kenneth Rohde Christiansen
<kenneth at webkit.org>

> +void LauncherWindow::selectViewportUpdateMode(int mode)

select is not a really good name for this. Consider using "change" or "set"


> +{
> +    if (!isGraphicsBased())
> +	   return;

I guess you should update the gViewportUpdateMode anyway, so you are bailing
out a bit too early

> +
> +    gViewportUpdateMode = QGraphicsView::ViewportUpdateMode(mode);
> +    WebViewGraphicsBased* view = static_cast<WebViewGraphicsBased*>(m_view);

> +    view->setViewportUpdateMode(gViewportUpdateMode);
> +}


More information about the webkit-reviews mailing list