[webkit-reviews] review denied: [Bug 34907] audio engine: add FFTConvolver class : [Attachment 48668] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 12 04:29:33 PST 2010


Jeremy Orlow <jorlow at chromium.org> has denied Chris Rogers
<crogers at google.com>'s request for review:
Bug 34907: audio engine: add FFTConvolver class
https://bugs.webkit.org/show_bug.cgi?id=34907

Attachment 48668: Patch
https://bugs.webkit.org/attachment.cgi?id=48668&action=review

------- Additional Comments from Jeremy Orlow <jorlow at chromium.org>
Looking pretty good.


> diff --git a/WebCore/platform/audio/FFTConvolver.cpp
b/WebCore/platform/audio/FFTConvolver.cpp
> new file mode 100644
> index 0000000..3c06dcc
> --- /dev/null
> +++ b/WebCore/platform/audio/FFTConvolver.cpp
> @@ -0,0 +1,94 @@
> +/*
> + * Copyright (C) 2010 Google Inc. All rights reserved.
> + *
> + * Redistribution and use in source and binary forms, with or without
> + * modification, are permitted provided that the following conditions
> + * are met:
> + *
> + * 1.  Redistributions of source code must retain the above copyright
> + *	  notice, this list of conditions and the following disclaimer.
> + * 2.  Redistributions in binary form must reproduce the above copyright
> + *	  notice, this list of conditions and the following disclaimer in the
> + *	  documentation and/or other materials provided with the distribution.
> + * 3.  Neither the name of Apple Computer, Inc. ("Apple") nor the names of
> + *	  its contributors may be used to endorse or promote products derived
> + *	  from this software without specific prior written permission.
> + *
> + * THIS SOFTWARE IS PROVIDED BY APPLE AND ITS CONTRIBUTORS "AS IS" AND ANY
> + * EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED

> + * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
> + * DISCLAIMED. IN NO EVENT SHALL APPLE OR ITS CONTRIBUTORS BE LIABLE FOR ANY

> + * DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES
> + * (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES;
> + * LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
AND
> + * ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
TORT
> + * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
> + * THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
> + */
> +
> +#include "config.h"
> +#include "FFTConvolver.h"
> +
> +namespace WebCore {
> +
> +FFTConvolver::FFTConvolver(size_t fftSize)
> +    : m_frame(fftSize)
> +    , m_readWriteIndex(0)
> +    , m_inputBuffer(fftSize) // 2nd half of buffer is always zeroed
> +    , m_outputBuffer(fftSize)
> +    , m_lastOverlapBuffer(fftSize / 2)
> +{
> +}
> +
> +void FFTConvolver::process(FFTFrame* fftKernel,
> +			      float* sourceP,
> +			      float* destP,
> +			      size_t framesToProcess)
> +{
> +    // FIXME : make so |framesToProcess| is not required to fit evenly into
fftSize/2

No space between FIXME and :.

> +
> +    // Copy samples to input buffer (note contraint above!)

Can we ASSERT anything there?

> +    float* inputP = m_inputBuffer;
> +    memcpy(inputP + m_readWriteIndex, sourceP, sizeof(float) *
framesToProcess);
> +
> +    // Copy samples from output buffer
> +    float* outputP = m_outputBuffer;
> +    memcpy(destP, outputP + m_readWriteIndex, sizeof(float) *
framesToProcess);
> +
> +    m_readWriteIndex += framesToProcess;
> +
> +    size_t halfSize = fftSize() / 2;
> +
> +    // Check if it's time to perform the next FFT
> +    if (m_readWriteIndex == halfSize) {
> +	   // The input buffer is now filled (get frequency-domain version)
> +	   m_frame.doFFT(m_inputBuffer);
> +	   m_frame.multiply(*fftKernel);
> +	   m_frame.doInverseFFT(m_outputBuffer);
> +
> +	   // Overlap-add 1st half from previous time
> +	   vadd(m_outputBuffer,
> +		1,
> +		m_lastOverlapBuffer,
> +		1,
> +		m_outputBuffer,
> +		1,
> +		halfSize);

The WebKit standard is to put the whole function call on one line.  I don't see
much of a readability improvement by splitting this over multiple lines, so I
think it'd probably be best if you just did that.

> +
> +	   // Finally, save 2nd half of result
> +	   memcpy((float*)m_lastOverlapBuffer,
> +		  (float*)m_outputBuffer + halfSize,
> +		  sizeof(float) * halfSize);

Ditto.

> +
> +	   // Reset index back to start for next time
> +	   m_readWriteIndex = 0;
> +    }
> +}
> +
> +void FFTConvolver::reset()
> +{
> +    m_lastOverlapBuffer.zero();
> +    m_readWriteIndex = 0;
> +}
> +
> +} // namespace WebCore
> diff --git a/WebCore/platform/audio/FFTConvolver.h
b/WebCore/platform/audio/FFTConvolver.h
> new file mode 100644
> index 0000000..20a4873
> --- /dev/null
> +++ b/WebCore/platform/audio/FFTConvolver.h
> @@ -0,0 +1,74 @@
> +/*
> + * Copyright (C) 2010 Google Inc. All rights reserved.
> + *
> + * Redistribution and use in source and binary forms, with or without
> + * modification, are permitted provided that the following conditions
> + * are met:
> + *
> + * 1.  Redistributions of source code must retain the above copyright
> + *	  notice, this list of conditions and the following disclaimer.
> + * 2.  Redistributions in binary form must reproduce the above copyright
> + *	  notice, this list of conditions and the following disclaimer in the
> + *	  documentation and/or other materials provided with the distribution.
> + * 3.  Neither the name of Apple Computer, Inc. ("Apple") nor the names of
> + *	  its contributors may be used to endorse or promote products derived
> + *	  from this software without specific prior written permission.
> + *
> + * THIS SOFTWARE IS PROVIDED BY APPLE AND ITS CONTRIBUTORS "AS IS" AND ANY
> + * EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED

> + * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
> + * DISCLAIMED. IN NO EVENT SHALL APPLE OR ITS CONTRIBUTORS BE LIABLE FOR ANY

> + * DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES
> + * (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES;
> + * LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
AND
> + * ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
TORT
> + * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
> + * THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
> + */
> +
> +#ifndef FFTConvolver_h
> +#define FFTConvolver_h
> +
> +#include "AudioFloatArray.h"
> +#include "FFTFrame.h"
> +
> +namespace WebCore {
> +
> +class FFTConvolver {
> +public:
> +    // |fftSize| must be a power of two

I think the fact that you're talking about the fftSize variable is clear
without the ||'s and they're not really used elsewhere in the code base.  Same
goes for other uses in comments.

> +    FFTConvolver(size_t fftSize);
> +
> +    // For now, with multiple calls to Process(), |framesToProcess| MUST add
up EXACTLY to |fftSize| / 2
> +    //
> +    // FIXME: Later, we can do more sophisticated buffering to relax this
requirement...
> +    //
> +    // The input to output latency is equal to |fftSize| / 2
> +    //
> +    // Processing in-place is allowed...
> +    void process(FFTFrame* fftKernel,
> +		    float* sourceP,
> +		    float* destP,
> +		    size_t framesToProcess);
> +
> +    void reset();
> +
> +    size_t fftSize() const { return m_frame.fftSize(); }
> +
> +private:
> +    FFTFrame m_frame;
> +
> +    // Buffer input until we get fftSize / 2 samples then do an FFT
> +    size_t m_readWriteIndex;
> +    AudioFloatArray m_inputBuffer;
> +
> +    // Stores output which we read a little at a time
> +    AudioFloatArray m_outputBuffer;
> +
> +    // Saves the 2nd half of the FFT buffer, so we can do an overlap-add
with the 1st half of the next one
> +    AudioFloatArray m_lastOverlapBuffer;
> +};
> +
> +} // namespace WebCore
> +
> +#endif // FFTConvolver_h


More information about the webkit-reviews mailing list