[webkit-reviews] review granted: [Bug 35707] Implementing DOMFormData class : [Attachment 50249] Move DOMFormData to html/

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Mar 10 15:14:30 PST 2010


Dmitry Titov <dimich at chromium.org> has granted Jian Li <jianli at chromium.org>'s
request for review:
Bug 35707: Implementing DOMFormData class
https://bugs.webkit.org/show_bug.cgi?id=35707

Attachment 50249: Move DOMFormData to html/
https://bugs.webkit.org/attachment.cgi?id=50249&action=review

------- Additional Comments from Dmitry Titov <dimich at chromium.org>
r=me, with a coupel of nits that can be fixed on landing:

> diff --git a/WebCore/html/DOMFormData.cpp b/WebCore/html/DOMFormData.cpp
> +DOMFormData::DOMFormData(const TextEncoding& encoding) :
FormDataList(encoding)

": FormDataList(encoding)" should be on a separate line

> diff --git a/WebCore/html/HTMLFormElement.h b/WebCore/html/HTMLFormElement.h

> +class DOMFormData;

Seems this declaration is not needed.

> diff --git a/WebCore/platform/network/FormData.h
b/WebCore/platform/network/FormData.h
> +    static PassRefPtr<FormData> create(const DOMFormData&, bool
isMultiPartForm, Document*);

It'd be better for readability if instead of 'bool' this parameter was an enum,
something like:
enum  { CreateRegularForm, CreateMultiPartForm };


More information about the webkit-reviews mailing list