[webkit-reviews] review denied: [Bug 41236] Autocomplete entries are missing when AutoFill entries are shown in the suggestions popup on Chrome : [Attachment 59820] Proposed patch, fixed style issues.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 30 09:04:34 PDT 2010


Darin Fisher (:fishd, Google) <fishd at chromium.org> has denied David Holloway
<dhollowa at chromium.org>'s request for review:
Bug 41236: Autocomplete entries are missing when AutoFill entries are shown in
the suggestions popup on Chrome
https://bugs.webkit.org/show_bug.cgi?id=41236

Attachment 59820: Proposed patch, fixed style issues.
https://bugs.webkit.org/attachment.cgi?id=59820&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd at chromium.org>
WebKit/chromium/public/WebFrame.h:490
 +	    WebInputElement) = 0;
please pass a WebInputElement using a const ref.  |const WebInputElement&|
WebKit/chromium/public/WebFrame.h:489
 +	virtual void notifiyPasswordListenerOfAutocomplete(
elsewhere you seem to be converging on the term autofill, but here
you still use the term autocomplete.  should this use autofill?

WebKit/chromium/public/WebView.h:243
 +	    int separatorIndex) = 0;
was this parameter just misnamed before?  defaultSuggestionIndex
and separatorIndex seem like very different things.

WebKit/chromium/src/WebFrameImpl.cpp:1967
 +	RefPtr<HTMLInputElement> element = inputElement.operator
PassRefPtr<HTMLInputElement>();
I don't think we should be invoking an operator this way.  Can't you
just write it like this:

  RefPtr<HTMLInputElement> element(inputElement);

That should cause inputElement to be implicitly converted to
PassRefPtr<HTMLInputElement> to fit the RefPtr constructor.

Overall, looks fine to me.  Please make sure that Jay has
reviewed this patch as well.


More information about the webkit-reviews mailing list