[webkit-reviews] review denied: [Bug 40301] DOM storage should only create databases when needed : [Attachment 58154] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 9 03:00:00 PDT 2010


Jeremy Orlow <jorlow at chromium.org> has denied hans at chromium.org's request for
review:
Bug 40301: DOM storage should only create databases when needed
https://bugs.webkit.org/show_bug.cgi?id=40301

Attachment 58154: Patch
https://bugs.webkit.org/attachment.cgi?id=58154&action=review

------- Additional Comments from Jeremy Orlow <jorlow at chromium.org>
WebCore/storage/StorageAreaSync.cpp:66
 +	, m_triedOpeningDatabase(false)
How about m_databaseOpenFailed

WebCore/storage/StorageAreaSync.cpp:206
 +	ASSERT(!m_database.isOpen());
Assert we haven't tried yet.

WebCore/storage/StorageAreaSync.h:79
 +	      CreateDatabase,
These names are not very clear.  The point is that creation is allowed, but
this sounds like you're saying always create it.

WebCore/storage/StorageAreaSync.cpp:307
 +	if (!m_database.isOpen() && !m_triedOpeningDatabase)
If you change the name as I suggested, then you can simply do "if
m_databaseOpenFailed return;" before this statement.  I think it's more clear.


More information about the webkit-reviews mailing list