[webkit-reviews] review denied: [Bug 40134] Web Inspector: sendMessageToFrontend implementation required. : [Attachment 58139] [patch] sixth iteration.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jun 8 12:56:33 PDT 2010


Pavel Feldman <pfeldman at chromium.org> has denied Ilya Tikhonovsky
<loislo at chromium.org>'s request for review:
Bug 40134: Web Inspector: sendMessageToFrontend implementation required.
https://bugs.webkit.org/show_bug.cgi?id=40134

Attachment 58139: [patch] sixth iteration. 
https://bugs.webkit.org/attachment.cgi?id=58139&action=review

------- Additional Comments from Pavel Feldman <pfeldman at chromium.org>
One minor cleanup and we are good to land!


WebKit/gtk/WebCoreSupport/InspectorClientGtk.cpp:168
 +	m_inspectorClient->closeInspectorClient();
closeInspectorFrontend() ? Also, I'd name it "releaseFrontendPage" since it
better reflects what it does.




WebKit/haiku/WebCoreSupport/InspectorClientHaiku.cpp:50
 +  void InspectorClientHaiku::closeInspectorFrontend()
nuke it

WebKit/haiku/WebCoreSupport/InspectorClientHaiku.h:46
 +	    virtual void closeInspectorFrontend();
ditto

WebKit/mac/WebCoreSupport/WebInspectorClient.h:58
 +	virtual void closeInspectorFrontend();
same recommendation on the name...

WebKit/qt/WebCoreSupport/InspectorClientQt.cpp:113
 +  void InspectorClientQt::closeInspectorFrontend()
ditto

WebKit/wx/WebKitSupport/InspectorClientWx.cpp:55
 +  void InspectorClientWx::closeInspectorFrontend()
nuke


More information about the webkit-reviews mailing list