[webkit-reviews] review denied: [Bug 40301] DOM storage should only create databases when needed : [Attachment 58140] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jun 8 08:24:06 PDT 2010


Jeremy Orlow <jorlow at chromium.org> has denied hans at chromium.org's request for
review:
Bug 40301: DOM storage should only create databases when needed
https://bugs.webkit.org/show_bug.cgi?id=40301

Attachment 58140: Patch
https://bugs.webkit.org/attachment.cgi?id=58140&action=review

------- Additional Comments from Jeremy Orlow <jorlow at chromium.org>
WebCore/storage/StorageAreaSync.cpp:306
 +	if (!m_database.isOpen())
Is it safe to do this?	What happens if it fails the first 2 times (the HD is
full or something) but later starts succeeding.  Please verify it'll do the
right thing.

I'd lean towards a m_initialized flag.

But is any of this needed?  Isn't the initial import guaranteed to run first?

WebCore/storage/StorageAreaSync.cpp:202
 +  void StorageAreaSync::openDatabase(bool create)
Create an enum instead of a bool for create and don't create.  It makes code
easier to read.

WebCore/ChangeLog:12
 +	    Tested by visiting e.g. http://people.w3.org/mike/localstorage.html
and verifying that no file is created in ~/Library/Safari/LocalStorage until
something is stored.
Create a manual-test in WebCore/manual-tests


More information about the webkit-reviews mailing list