[webkit-reviews] review granted: [Bug 42367] Speech input plumbing in webkit : [Attachment 62432] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 23 10:08:10 PDT 2010


Darin Fisher (:fishd, Google) <fishd at chromium.org> has granted Satish Sampath
<satish at chromium.org>'s request for review:
Bug 42367: Speech input plumbing in webkit
https://bugs.webkit.org/show_bug.cgi?id=42367

Attachment 62432: Patch
https://bugs.webkit.org/attachment.cgi?id=62432&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd at chromium.org>
WebKit/chromium/public/WebViewClient.h:341
 +	virtual WebSpeechInputController* createSpeechInputController(
this method is named create*, yet it returns an interface that defines
a protected virtual destructor, so i have no way to destroy the thing
that was created for me.  perhaps you don't intend to allocate a new
WebSpeechInputController each time this method is called?  if that is
the case, then this method should just have the create prefix dropped.
it should just be named "speechInputController".

cleaning up the webcore classes in a separate patch is completely fine.
my concern with this patch is that the interfaces should match up well
with what we want the webcore classes to look like.  i'm happy if that's
the plan.

R=me with createSpeechInputController renamed to speechInputController.


More information about the webkit-reviews mailing list