[webkit-reviews] review granted: [Bug 42587] Handle NP_ASFILE and NP_ASFILEONLY transfer modes : [Attachment 61984] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 19 13:28:39 PDT 2010


Darin Adler <darin at apple.com> has granted Anders Carlsson
<andersca at apple.com>'s request for review:
Bug 42587: Handle NP_ASFILE and NP_ASFILEONLY transfer modes
https://bugs.webkit.org/show_bug.cgi?id=42587

Attachment 61984: Patch
https://bugs.webkit.org/attachment.cgi?id=61984&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
> +    return CString(temporaryFilePath.data());

Does the CString constructor really require a vector that already has the '\0'
in it? Or does this code end up adding two of them?

> +    void NPP_StreamAsFile(NPStream* stream, const char* filename);

Leave out the "stream" argument name?

> +    RefPtr<PluginView::Stream> stream = m_streams.get(streamID).get();

Here inside the class we can just call it Stream instead of PluginView::Stream.


More information about the webkit-reviews mailing list