[webkit-reviews] review granted: [Bug 42018] Implement Web Timing redirectStart, redirectEnd, redirectCount : [Attachment 61183] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 12 22:22:07 PDT 2010


Darin Fisher (:fishd, Google) <fishd at chromium.org> has granted Tony Gentilcore
<tonyg at chromium.org>'s request for review:
Bug 42018: Implement Web Timing redirectStart, redirectEnd, redirectCount
https://bugs.webkit.org/show_bug.cgi?id=42018

Attachment 61183: Patch
https://bugs.webkit.org/attachment.cgi?id=61183&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd at chromium.org>
WebCore/loader/FrameLoaderTypes.h:64
 +	    FrameLoadTimeline()
i'm a little surprised to see this struct defined in this file.
i always thought of this file as the place to put loader defined
enums.	normally, webkit has the style rule that you create a
new file for each struct or class.

WebCore/loader/MainResourceLoader.cpp:166
 +	    frameLoadTimeline->redirectEnd = currentTime();
it might be good to call currentTime only once and then use that value
for both redirectEnd and fetchStart.  i think it is not wrong for them
to be different, but it also seems ok (perhaps good) to say that they
are exactly the same.

R=me


More information about the webkit-reviews mailing list