[webkit-reviews] review granted: [Bug 41607] DeviceOrientationEvent should use optional properties : [Attachment 61208] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 12 06:17:30 PDT 2010


Jeremy Orlow <jorlow at chromium.org> has granted Steve Block
<steveblock at google.com>'s request for review:
Bug 41607: DeviceOrientationEvent should use optional properties
https://bugs.webkit.org/show_bug.cgi?id=41607

Attachment 61208: Patch
https://bugs.webkit.org/attachment.cgi?id=61208&action=review

------- Additional Comments from Jeremy Orlow <jorlow at chromium.org>

LayoutTests/fast/dom/DeviceOrientation/script-tests/optional-event-properties.j
s:39
 +  event.initDeviceOrientationEvent("", false, false, null, null, null);
if you used evalAndLog, then this would be printed to the console too, so it'd
be easier to read without much additional effort.

WebCore/dom/DeviceOrientation.h:53
 +	DeviceOrientation()
There's enough code here I'd lean towards putting it in a .cpp file.

WebCore/bindings/js/JSDeviceOrientationEventCustom.cpp:2
 +   * Copyright 2010, The Android Open Source Project
Since these contributions are for sure from Google, should the copyright just
read Google?


More information about the webkit-reviews mailing list