[webkit-reviews] review denied: [Bug 41286] [chromium] EditorClient should forward text field related calls to the WebViewClient : [Attachment 59930] First version of the patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 2 13:38:34 PDT 2010


Darin Fisher (:fishd, Google) <fishd at chromium.org> has denied Jay Civelli
<jcivelli at chromium.org>'s request for review:
Bug 41286: [chromium] EditorClient should forward text field related calls to
the WebViewClient
https://bugs.webkit.org/show_bug.cgi?id=41286

Attachment 59930: First version of the patch
https://bugs.webkit.org/attachment.cgi?id=59930&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd at chromium.org>
WebKit/chromium/src/EditorClientImpl.cpp:823
 +	HTMLInputElement* inputElement = WebKit::toHTMLInputElement(element);
EditorClientImpl is defined in the WebKit namespace, so you don't
need to have the WebKit:: prefix before toHTMLInputElement.

WebKit/chromium/public/WebViewClient.h:146
 +	virtual void textFieldHandlingKeyDown(const WebInputElement&, const
WebKeyboardEvent&) { }
textFieldDidReceiveKeyDown?

WebKit/chromium/public/WebViewClient.h:144
 +	virtual void textDidChangeInTextField(const WebInputElement&) { }
textFieldDidChange?

WebKit/chromium/public/WebInputElement.h:83
 +	    WEBKIT_API bool readOnly() const;
hmm... maybe this should be named isReadOnly to match isEnabledFormControl.
i know you are just replicating readOnly from the WebCore name.

looks good otherwise.


More information about the webkit-reviews mailing list