[webkit-reviews] review granted: [Bug 34332] Web Inspector: Lazy-load resource contents in the Resources panel : [Attachment 47720] [PATCH] Proposed solution

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 29 17:52:37 PST 2010


Timothy Hatcher <timothy at hatcher.name> has granted Alexander Pavlov (apavlov)
<apavlov at chromium.org>'s request for review:
Bug 34332: Web Inspector: Lazy-load resource contents in the Resources panel
https://bugs.webkit.org/show_bug.cgi?id=34332

Attachment 47720: [PATCH] Proposed solution
https://bugs.webkit.org/attachment.cgi?id=47720&action=review

------- Additional Comments from Timothy Hatcher <timothy at hatcher.name>
> +    ensureResourceLoaded: function()

ensureResourceIsLoaded would be a better name.

> +	   if (resource._resourcesView && "setLazyLoad" in
resource._resourcesView)
> +	       resource._resourcesView.setLazyLoad(lazyLoad);

Why not just set the property directly? When would the setLazyLoad function not
exist? Use a setter instead of a function, or just set the property directly.

Fix these before landing.


More information about the webkit-reviews mailing list