[webkit-reviews] review granted: [Bug 33957] [v8] Implement Node map in intrusive way for better speed : [Attachment 47372] Refactoring underlying storage into ChunkedTable

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 25 16:21:24 PST 2010


Adam Barth <abarth at webkit.org> has granted anton muhin <antonm at chromium.org>'s
request for review:
Bug 33957: [v8] Implement Node map in intrusive way for better speed
https://bugs.webkit.org/show_bug.cgi?id=33957

Attachment 47372: Refactoring underlying storage into ChunkedTable
https://bugs.webkit.org/attachment.cgi?id=47372&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
+ m_table()

You don't need to call the default constructor explicitly.

+ static int const kNoEntries = (1 << 10) - 1;

Perhaps numberOfEntries?  (WebKit-land doesn't use "k" and the No is
confusing).

Thanks for factoring ChunkedTable out.	It's much easier to follow what's going
on abstractly.	As we discussed, we should move ChunkedTable to a more generic
location in a future patch.

Looks great!  I wish we had some unit testing for ChunkedTable, but that's not
the way WebKit rolls.


More information about the webkit-reviews mailing list