[webkit-reviews] review granted: [Bug 33783] [DRT][Mac] Add modifiers parameter to mouseDown() and mouseUp() : [Attachment 46876] Proposed patch (rev.2)

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 19 08:26:34 PST 2010


Darin Adler <darin at apple.com> has granted TAMURA, Kent <tkent at chromium.org>'s
request for review:
Bug 33783: [DRT][Mac] Add modifiers parameter to mouseDown() and mouseUp()
https://bugs.webkit.org/show_bug.cgi?id=33783

Attachment 46876: Proposed patch (rev.2)
https://bugs.webkit.org/attachment.cgi?id=46876&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
Looks fine.

r=me

Not directly related to this patch: I realize now that the use of
performSelector:withObject: is already wrong for mouseDown: and mouseUp: since
they have an argument that is not an object. Someone should clean this up in
the future. I think we can just replace mouseDown: and mouseUp: with
mouseDownButton0 and mouseUpButton0 methods that don't take arguments at all.


More information about the webkit-reviews mailing list