[webkit-reviews] review granted: [Bug 33563] Transition followed by animation fails to run the animation sometimes : [Attachment 46501] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 13 15:37:51 PST 2010


Darin Adler <darin at apple.com> has granted Simon Fraser (smfr)
<simon.fraser at apple.com>'s request for review:
Bug 33563: Transition followed by animation fails to run the animation
sometimes
https://bugs.webkit.org/show_bug.cgi?id=33563

Attachment 46501: Patch
https://bugs.webkit.org/attachment.cgi?id=46501&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
> +	   Fix this by including they keyframes name (or empty string for
transitions) in the labels

Typo: "they keyframes"

> +	   * platform/graphics/mac/GraphicsLayerCA.h: Some new methods and
signataure changes.

Typo: "signataure"

> +    void setAnimationOnLayer(CAPropertyAnimation*, AnimatedPropertyID, const
String&, int index, double timeOffset);
> +    bool removeAnimationFromLayer(AnimatedPropertyID, const String&, int
index);
> +    void pauseAnimationOnLayer(AnimatedPropertyID, const String&, int index,
double timeOffset);

I think these new string arguments need an argument name for clarity.

>      String animationId = propertyIdToString(property);
>      animationId.append("_");
> +    if (!keyframesName.isEmpty()) {
> +	   animationId.append(keyframesName);
> +	   animationId.append("_");
> +    }
> +    animationId.append("_");
>      animationId.append(String::number(index));

This function is using an inefficient idiom for building a String. The String
class allocates a new buffer every time you append to it. You should use
StringBuilder or Vector<UChar> or some other alternate strategy.

r=me


More information about the webkit-reviews mailing list