[webkit-reviews] review denied: [Bug 35213] [chromium] hardcoded gcc path breaks solaris build : [Attachment 49162] revised patch with reedited ChangeLog

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 22 00:02:35 PST 2010


Evan Martin <evan at chromium.org> has denied electricmonopole at gmail.com's request
for review:
Bug 35213: [chromium] hardcoded gcc path breaks solaris build
https://bugs.webkit.org/show_bug.cgi?id=35213

Attachment 49162: revised patch with reedited ChangeLog
https://bugs.webkit.org/attachment.cgi?id=49162&action=review

------- Additional Comments from Evan Martin <evan at chromium.org>
r- based on Darin's comments.  It looks like patch #3 has different changes
than patch #2.

-    open FILE, "-|", "/usr/bin/gcc", "-E", "-P", "-x", "objective-c", 
-	 (map { "-D$_" } split(/ +/, $defines)), "-DOBJC_CODE_GENERATION",
$fileName or die "Could not open $fileName";
+    if (($Config::Config{'osname'})=~/solaris/i){
+	 open FILE, "-|", "/usr/sfw/bin/gcc", "-E", "-P", "-x", "objective-c", 

+	     (map { "-D$_" } split(/ +/, $defines)), "-DOBJC_CODE_GENERATION",
$fileName or die "Could not open $fileName";
+    } else {
+	 open FILE, "-|", "/usr/bin/gcc", "-E", "-P", "-x", "objective-c", 
+	     (map { "-D$_" } split(/ +/, $defines)), "-DOBJC_CODE_GENERATION",
$fileName or die "Could not open $fileName";
+    }

Rather than duplicate code, why not factor out the gcc path into a variable?


More information about the webkit-reviews mailing list