[webkit-reviews] review granted: [Bug 34652] [chromium] Add the chromium interface to support Blob.slice. : [Attachment 48429] Proposed Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 9 12:00:36 PST 2010


Darin Fisher (:fishd, Google) <fishd at chromium.org> has granted Jian Li
<jianli at chromium.org>'s request for review:
Bug 34652: [chromium] Add the chromium interface to support Blob.slice.
https://bugs.webkit.org/show_bug.cgi?id=34652

Attachment 48429: Proposed Patch
https://bugs.webkit.org/attachment.cgi?id=48429&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd at chromium.org>
> +++ b/WebKit/chromium/public/WebFileInfo.h
...
> +#include "WebString.h"

^^^ you can nuke this include now.


> +++ b/WebKit/chromium/public/WebHTTPBody.h

> +	   long long fileStart;
> +	   long long fileLength; // -1 means the whole file.

^^^ nit: -1 means to the end of the file.  it would only mean the whole file
if fileStart were 0.


> +    WEBKIT_API void appendFile(const WebString&); // FIXME: to be removed.
> +    WEBKIT_API void appendFile(const WebString&, long long fileStart, long
long fileLength, const WebFileInfo&);

^^^ please document the magic value of -1 here as well for fileLength.


otherwise, LGTM.  R=me, assuming you fixup these nits before committing.


More information about the webkit-reviews mailing list