[webkit-reviews] review denied: [Bug 34655] [chromium] Change chromium interface to handle DownloadURL format. : [Attachment 48244] Proposed Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Feb 6 12:35:48 PST 2010


Darin Fisher (:fishd, Google) <fishd at chromium.org> has denied Jian Li
<jianli at chromium.org>'s request for review:
Bug 34655: [chromium] Change chromium interface to handle DownloadURL format.
https://bugs.webkit.org/show_bug.cgi?id=34655

Attachment 48244: Proposed Patch
https://bugs.webkit.org/attachment.cgi?id=48244&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd at chromium.org>
> +++ b/WebCore/platform/chromium/ChromiumDataObject.cpp
> @@ -38,6 +38,7 @@ void ChromiumDataObject::clear()
>      url = KURL();
>      urlTitle = "";
>      downloadURL = KURL();
> +    downloadMetadata = "";

nit: should be "downloadMetaData" <-- cap "Data"


> +++ b/WebKit/chromium/public/WebDragData.h
> @@ -74,6 +74,8 @@ public:
>  
>      WEBKIT_API WebURL downloadURL() const;
>      WEBKIT_API void setDownloadURL(const WebURL&);
> +    WEBKIT_API WebString downloadMetadata() const;
> +    WEBKIT_API void setDownloadMetadata(const WebString&);

same nit: should be named downloadMetaData and setDownloadMetaData


otherwise, this LGTM


More information about the webkit-reviews mailing list