[webkit-reviews] review granted: [Bug 51303] check-webkit-style should detect function declarations (and trivial functions). : [Attachment 76955] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Dec 19 12:32:13 PST 2010


Shinichiro Hamaji <hamaji at chromium.org> has granted David Levin
<levin at chromium.org>'s request for review:
Bug 51303: check-webkit-style should detect function declarations (and trivial
functions).
https://bugs.webkit.org/show_bug.cgi?id=51303

Attachment 76955: Patch
https://bugs.webkit.org/attachment.cgi?id=76955&action=review

------- Additional Comments from Shinichiro Hamaji <hamaji at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=76955&action=review

Looks good, putting some nitpicks on test. Please feel free to ignore some of
(or even all of) them if they don't make sense.

> Tools/Scripts/webkitpy/style/checkers/cpp_unittest.py:240
> +	   if not function_information:

I'd add a trivial test case which passes this case. Not sure, but "if (foobar)
{ something... }" or "for (foobar;...) { ... }" would be good candidates?

> Tools/Scripts/webkitpy/style/checkers/cpp_unittest.py:2818
> +	   self.assert_pass_ptr_check(

s/pass_ptr/pass_ref_ptr/ ?

> Tools/Scripts/webkitpy/style/checkers/cpp_unittest.py:2823
> +	   self.assert_pass_ptr_check(

s/pass_ptr/pass_ref_ptr/ ?

> Tools/Scripts/webkitpy/style/checkers/cpp_unittest.py:2837
> +	       '    PassRefPtr<Type1> m_other;\n'

I guess RefPtr would be more realistic?


More information about the webkit-reviews mailing list