[webkit-reviews] review granted: [Bug 50698] [GTK] Split webkitprivate.{cpp, h} in more manageable chunks : [Attachment 76218] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 10 15:32:24 PST 2010


Martin Robinson <mrobinson at webkit.org> has granted Gustavo Noronha (kov)
<gns at gnome.org>'s request for review:
Bug 50698: [GTK] Split webkitprivate.{cpp,h} in more manageable chunks
https://bugs.webkit.org/show_bug.cgi?id=50698

Attachment 76218: Patch
https://bugs.webkit.org/attachment.cgi?id=76218&action=review

------- Additional Comments from Martin Robinson <mrobinson at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=76218&action=review

Yay! Please fix the small nits before landing.

> WebKit/gtk/webkit/webkitdownloadprivate.h:33
> +void
> +webkit_download_set_suggested_filename(WebKitDownload*, const gchar*
suggestedFilename);

This should probably be one line here.

> WebKit/gtk/webkit/webkitwebnavigationactionprivate.h:31
> +WebKitWebNavigationReason kit(WebCore::NavigationType type);
> +WebCore::NavigationType core(WebKitWebNavigationReason reason);

I think you can delete these variable names.

> WebKit/gtk/webkit/webkitwebresourceprivate.h:46
> +WebKitWebResource*
>
+webkit_web_resource_new_with_core_resource(PassRefPtr<WebCore::ArchiveResource
>);
> +
> +void
> +webkit_web_resource_init_with_core_resource(WebKitWebResource*,
PassRefPtr<WebCore::ArchiveResource>);

I think maybe no extra newlines here.


More information about the webkit-reviews mailing list